KrakenD framework joins the Linux Foundation. Read more.

Community docs (current)

Recent changes

Plugin and dependencies validator

The plugin validator is an online tool that allows you to find problems with your plugin dependencies. Go plugins are strict on which versions of libraries you can use, so it’s important to make sure that your dependencies are compatible with the selected KrakenD versions.

Access the online plugin validation tools

The plugin validator checks your go.sum file to find problems and reports all associated problems. From which Go version is supported, to which individual libraries will conflict during runtime.

Go to plugin validator

The dependencies list shows all libraries used by KrakenD. Make sure your plugins use the same versions:

Go to dependencies finder

Unresolved issues?

The documentation is only a piece of the help you can get! Whether you are looking for Open Source or Enterprise support, see more support channels that can help you.

We use cookies to understand how you use our site and to improve your overall experience. By continuing to use our site, you accept our Privacy Policy. More information